How to get a professional online presence

Bacs upgrade to improve security

In response to security risks, more advanced levels of internet security are being introduced that might have implications if you are using Bacs payments.

From 13 June 2016, Bacs will withdraw support for older connection protocols and only support TLS 1.1 and 1.2. Firms using Bacs will need to have a web browser, operating system, and Bacs Approved Software Solution that supports the changes.

You may be unable to use Bacs to pay wages or suppliers, or use direct debit, if you do not make the necessary changes; and those using Payment Services Website to collect reports will also need to make the upgrades.

Further information here.

Share this page on social media

Written on May 24, 2016Mike Cartwright. Published in Finance, IT & Telecoms, News